कि threadsafe हो गया है एक NSAPI प्लगइन है कि Sybase कहता है, लिखने के लिए सुझाव

वोट
1

मैं एक समय Sybase प्रलेखन अगर 12.5 ग्राहक धागा सुरक्षित है का कहना है कि खोजने की कोशिश की एक नरक हो रही है। मैं Sybase threadsafe कॉल क्योंकि मैं जो एक थ्रेडेड वातावरण में रहती है एक NSAPI प्लगइन लिख रहा हूँ बनाने की जरूरत है। तो या तो मुझे यकीन है कि Sybase ग्राहक एक थ्रेडेड वातावरण में चला सकते हैं बनाने की जरूरत है या मैं Sybase जो नीचे मेरी वेबसर्वर अत्यंत धीमी हो जाएगी करने के लिए कॉल को क्रमानुसार करने की जरूरत होगी। सुझाव?

12/03/2009 को 17:18
का स्रोत उपयोगकर्ता
अन्य भाषाओं में...                            


1 जवाब

वोट
0

12.5.1 खुला ग्राहक सुरक्षित थ्रेड है, तो आप सिर्फ सही पुस्तकालय से जोड़ने के लिए की जरूरत है।

इस रिलीज के रूप में, ओपन क्लाइंट का धागा सुरक्षित संस्करण / सी पुस्तकालयों POSIX धागे का उपयोग कर लिखा है। सभी बहु-क्रम पुस्तकालयों स्थिर पुस्तकालयों के लिए नामकरण पैटर्न * _r.a या * साझा पुस्तकालयों के लिए _r.so का उपयोग करें। बहु अनुप्रयोगों के लिए, इस तरह के libcs_r.a के रूप में "_R" प्रत्यय के साथ पुस्तकालयों, का उपयोग करें। गैर बहु ​​अनुप्रयोगों के लिए, इस तरह के libcs.a के रूप में "_R" प्रत्यय के बिना पुस्तकालयों, का उपयोग करें।

http://download.sybase.com/pdfdocs/sdr1251e/ocssun04.pdf

12/03/2009 को 18:44
का स्रोत उपयोगकर्ता

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more